Jump to content


i need feedback on new website speed please :)

  • Please log in to reply
46 replies to this topic

#31 CarrieRN

  • Member
  • 815 posts

    Posted 26 February 2008 - 01:28 PM

    I have Fios internet. I did look at all the pics but I clicked on each thumbnail. It took 3sec to load after I clicked. I love your photos.
    Philip at 1 yr old. Go Steelers!
    Soon I will get to post wedding pics, figure I should get some more Philip in first!


    #32 Dbld78

    • Banned
    • 665 posts

      Posted 26 February 2008 - 02:07 PM

      being a professional photographer first and bride second, i fing love it! i want to redo my own site, is it livebooks or did you use someone else?

      your work is BEAUTIFUL! love you grainy bws and your cross processed colors nice saturation! are you using film? if you are kudos....that's a huge deal in our all digital world!

      #33 leigh miller

      leigh miller
      • Member
      • 936 posts

        Posted 03 March 2008 - 12:44 AM

        hi danielle - thanks! its bludomain. and i shoot digital. im in love with grain right now though :) congrats on the engagement!

        #34 Sarah


          VIP Member

        • VIP Member
        • 6,996 posts

          Posted 03 March 2008 - 02:24 AM

          Hi Leigh! I missed this thread before!

          I love the new website and the large pictures. I think it really showcases your work well. The pictures took only 2-3 seconds to load, and I have Comcast high speed internet (cable). Can't wait to see the whole thing when it gets done.

          OK, being super picky here- I liked the softer green on your old/current website a little better than the green on the new website. Of course it's great how it is- just my two cents :)

          Hope you're doing well :)

          #35 Kristie O

          Kristie O
          • Banned
          • 369 posts

            Posted 03 March 2008 - 05:04 AM

            i have high speed internet, like im sure most photogs do and didnt notice the speed being a problem...it didnt seem too slow and im unpatient with stuff like that...also, the pics are so good, people will probably wait if it were slow for them.

            #36 jmill130

            • Member
            • 601 posts

              Posted 03 March 2008 - 08:43 AM

              Site looks great, it loads pretty fast on high speed cable. Love your work. I think the shots are worth the wait, timing seemed perfect.

              #37 leigh miller

              leigh miller
              • Member
              • 936 posts

                Posted 03 March 2008 - 12:15 PM

                thanks everyone! im hoping to get it done in the next month. i will let you know when its up. and i hear you sarah. im on the fence about the green change. thanks!

                #38 rodent


                  VIP Member

                • VIP Member
                • 18,759 posts

                  Posted 03 March 2008 - 12:26 PM

                  Now that this thread has been brought back to life, I watched the slide show again. The speed is perfect & I love the big pictures now. I think it was just a speed/ loading problem before that made me want little, quick click pictures.

                  #39 leigh miller

                  leigh miller
                  • Member
                  • 936 posts

                    Posted 03 March 2008 - 02:42 PM

                    thanks everyone. i made an adjustment to the program and it seems to make things go a lot faster. yeah! i was afraid id have to trash the site. i love the big pics too.

                    #40 leigh miller

                    leigh miller
                    • Member
                    • 936 posts

                      Posted 03 April 2008 - 01:28 PM

                      i finally have one wedding up and have adjusted the speed if anyone has time to take a look and tell me if its ok or too slow. thanks gals!!!

                      0 user(s) are reading this topic

                      0 members, 0 guests, 0 anonymous users